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Chapter 1:  Introduction  
Welcome to Server Technology’s Sentry Power Manager!  

Sentry Power Manager (SPM) is an appliance that provides real-time enterprise power management of Cabinet 
Distribution Units (CDUs) in one or more remote data center locations.  

SPM communicates with discovered CDUs in the network and allows you to monitor and manage remote CDUs in all 
locations from a single console. The SPM interface gives a top-level view of your data center with drill-down to 
operational details for each device SPM discovers in the network. You can quickly determine the overall status of your 
enterprise while managing the operating status of individual devices. 

Features of Sentry Power Manager: 

 Real-time CDU status and notification of alarms reported dynamically (using SNMP traps), to allow monitoring and 
 immediate outlet control over CDU operating conditions such as power, temperature, and humidity.  

 Generation of several high accuracy POPS energy usage reports based on individual outlets, devices, named outlet 
 groups/clusters, and the entire data center. 

 Server Technology’s “clustering” technology that gathers CDUs across individual IP addresses, multiple CDUs, or 
 the entire data center for power monitoring and calculating data center efficiency. 

 Availability of custom trend graphs generated with various operating parameters for temperature, humidity, infeed 
 load, and power.  

 A custom view of your data center as a hierarchy of several levels – locations, buildings, floors, rooms, and other 
 specific areas you configure. Background images and device icons let you view equipment conditions graphically by 
 status, load, power, and capacity, and provide drill-down from higher levels to detailed operating parameters.  

 

Technical Support  

 

Experience Server Technology's FREE SMARTER Technical Support - Learn more... 

Server Technology understands that there are often questions when installing and/or using a new product.  Free Technical 
Support is provided from 6:00 AM to 7:00 PM, Monday-Friday, Pacific Time. 

Server Technology, Inc. 
1040 Sandhill Drive Tel: 775.284.2000 Web: www.servertech.com 
Reno, Nevada  89521 USA Fax:  775.284.2065 Email: support@servertech.com 

 

http://www.servertech.com/support/SMARTERTechnicalSupport/�
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Chapter 2: Getting Started  
For the administrator: The following list summarizes the step-by-step tasks to help you quickly configure Sentry Power 
Manager (SPM) to build a graphical data center view, user base, and device connections. The configurations allow 
connection and communication with your current established network. 

NOTE: Before you begin, make sure SNMP is How to.  

For detailed information on each step, go to the page number listed to the right: 

Connect and Login 

Connect and login to Sentry Power Manager ........................................................................................ 8. 

Upon connection to SPM, a web browser is directed to the local IP address of the SPM server. You can then login as the 
default administrative user with username/password: admn/admn.  

Create a New Administrative Account 

Create a new administrative user account ............................................................................................. 51. 

For security it is recommended that you first use the default admn user account to grant access rights to another 
administrative user account. Use the new administrative account to then change the default admn account 
username/password. Note that the admn account cannot be deleted or demoted. 

Discover Network Devices 

Configure supported devices for discovery ............................................................................................ 43. 

Device management starts with adding Cabinet Distribution Units (CDUs) to the SPM network inventory. The Discovery 
feature adds devices in bulk (IP range) or individually (exact IP ) by searching for SNMP-enabled CDUs in the network to 
communicate with SPM. 

Configure Device Settings  

Locations: Configure locations  .............................................................................................................. 39. 

Import, configure, and manage default maps and custom images to be displayed on the Views page as the background for 
location, cabinet, and device icons. 

Cabinets: Configure cabinets .................................................................................................................. 45. 

Manage cabinets by adding, editing, and deleting; specify cabinet area (in square ft.) for calculation of power density; 
associate a cabinet with a location (background) image. 

CDUs: Configure CDUs .......................................................................................................................... 45. 

Configure CDUs by naming the CDU, establishing SNMP Get/Set parameters, providing device capacity, deleting CDUs, 
and associating a CDU with a cabinet/location.  

CDUs: OPTIONAL. Configure Environmental Monitor...................................................................... 46. 

If an environmental monitor is connected to a CDU, you can edit the environmental monitor name and sensor name(s) and 
set the high/low thresholds for temperature and humidity. 

CDUs: Configure Enclosures .................................................................................................................. 47. 

Edit the names of CDU components: enclosures, infeeds, and outlets; also allows configuration of load threshold (in 
amperes) and low/high power limits (in watts). 
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Configure User Groups and Grant Device Permissions 

Create user groups ................................................................................................................................... 53. 

Create a new user group and assign the user group to an access rights level (user type), such as administrative, regular 
user, view-only, or reboot-only. 

Assign user group permissions to networked devices ........................................................................... 56. 

Grant access rights by individual user groups to networked clusters, locations, cabinets, CDUs, and outlets.  

Configure New Users 

Create a new user and assign to a user group ....................................................................................... 51. 

Create a new user and password. Then assign the new user to a user group which has permissions granted to select 
network devices.  

Build a Graphical Data Center 

Select maps and images for Views page ................................................................................................. 39. 

Select default or custom location images as the graphical background to depict customized levels of your data center. 

Place a location icon  on a location (background) image ................................................................ 39. 

Associate a location icon with a location (background) image and position the icon on the image using the Views page. 

Place a cabinet icon  on a location (background) image ................................................................. 42. 

Associate a cabinet with a location image and position the icon on the image using the Views page. 

Place a CDU icon  on a location (background) image ........................................................................ 45. 

Associate a CDU with a location image and position the icon on the image using the Views page. 

Optional Features 

You can configure the following optional features of SPM in any order: 

Outlet Groups/Outlet Clusters 

Configure outlet groups/outlet clusters .................................................................................................. 48. 

Create outlet groups and/or outlet clusters for remote reboot and power information. Select outlets to associate with the 
outlet group/cluster.  

Light Directory Access Protocol (LDAP) 

 Configure LDAP parameters ................................................................................................................. 54. 

LDAP support with SPM enables authentication with LDAP servers so that user accounts do not need to be added 
individually to SPM. 

Email Notification 

Configure email notifications for system activity logs ........................................................................... 57.  

Send emails to designated users for Discovery, User Login, User Actions, and Alarm Status logs. 

Configure Network Settings 

Determine network settings .................................................................................................................... 57. 

Connect to, and communicate with, your current established network through email, system settings, network settings, and 
connections for web, telnet, serial, and the SPM database.   

Open Database Connectivity (ODBC) 

The ODBC is a technology that provides a non-proprietary interface for universal data access. SPM provides one-way 
external access via ODBC to other systems – data can be retrieved but not updated from an external source. A software 
key is required for the ODBC feature. 

NOTE: To purchase the ODBC option, please contact your Server Technology representative at 1-800-835-1515 (domestic), 
++0 (1) 775.284.2000 (international), or sales@servertech.com. 
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Chapter 3: Using Sentry Power Manager  
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System Requirements 

For the Web Browser 

The web browser requirements for Sentry Power Manager are: 

 Internet Explorer 8.0, 7.0, and 6.0 (service pack 1) or Mozilla Firefox 3.5, 3.0, and 2.0. 

 Recommended screen resolution: 1440 x 900. 

 Minimum screen resolution: 1024 x 768. 

Connecting to Sentry Power Manager 

Connecting to SPM requires directing a web browser to the IP address of the Sentry Power Manager server. 

Using the Web Connection 

Connect to the Sentry Power Manager default IP address at: http://192.168.1.254.  

SPM Login Page 

Connection to SPM displays the following login page: 

 

The username/password for the default administrative account is admn/admn.  

 

 

http://192.168.1.254/�
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Working with the Interface  

The following sections introduce the pages and features of the Sentry Power Manager (SPM) interface and provide 
instructions for using enterprise management functions. 

Touring the Views Page 

Views Menu Option 

Option Description 

Views Provides at-a-glace monitoring of enterprise locations, cabinets, and CDUs using color-coded icons positioned on 
background (location) images. The Views page displays networked equipment by the vantage points of operating 
status, load, power, temperature, humidity, or capacity. 

The Views page is the graphical overview of your data center that gives point-and-click monitoring of network status and 
control of discovered devices.   

 

Using Location Images 

Maps and other images are the backgrounds on the Views page where you place icons to depict various locations and 
devices in your data center. Location images represent the customized levels of your data center, such as buildings, floors, 
and rooms.   

The default global map and other default maps are installed with SPM, however, you can import your own graphics files 
(JPG, PNG, or GIF formats only) to use as custom location images.   

NOTE: Administrative user accounts have full access to the View page, including all default and custom location images. However, non-
administrative user accounts have limited access to the Views page until granted permissions by the administrator with Config > Users & 
Groups > Users and Config > Users & Groups > Permissions. 
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Acknowledging Alarms and CDU Status 

The Status box is the real-time graphical reporting of alarms and status changes 
occurring in a discovered CDU.  

SPM is an SNMP trap destination for the Sentry Switched and Smart CDUs, which 
allows the units to distribute alarm notifications and status reporting.  

The Status box displays in a fixed size and position in the left pane of the SPM interface. As a CDU communicates its 
status to SPM, status is reported in one of five categories shown in the Status box. SPM only reports status as received 
from a discovered CDU. The operating condition of the CDU determines the severity of the status category. 

Each status category in the Status box is represented by an icon, the category name, and the total number of CDUs 
currently reported in the category.  

To acknowledge a device reported in the Status box, click the icon for the category. The CDU > Manage option opens and 
displays the operating details of the reported CDU where you can review and manage the current condition of the CDU. 

The condition of a CDU is reported in one of five categories: 

Status Categories 

Status Description 

Critical CDU has developed a service-affecting condition that requires immediate corrective action. 

Warning Alerts the operator that a CDU is on-battery with a loss of utility power; the outlet may be scheduled to be turned 
off if not quickly remedied. 

Unreachable SPM cannot communicate with a CDU via the network and the CDU is placed in temporary unreachable status. 

Normal CDU does not show any warning or alarm conditions and is operating normally within thresholds. 

Maintenance CDU remains for the time period specified or until manually removed.  

Choosing Location Images for the Data Center 

The drop-down list in the upper left of the Views page shows the graphic files installed with SPM (and administrator-
enabled), as well as any custom graphic files the administrator added and enabled using Config > Locations. 
 

Any graphic files (such as maps or custom images) in the drop-down 
list are the backgrounds that represent different levels of your data 
center, such as a building, floor, room, or other specific area. 

The graphics files display in the drop-down list by the name assigned 
by the administrator. The file you select from the list provides the 
working background in the Views page where you place icons 
representing data center locations, cabinets, and CDUs. Acceptable 
formats for the graphics files JPG, PNG, and GIF. 

 

In the example above, “Continental USA” was selected as the location image, showing two round location icons that were 
placed by the administrator to represent a data center location in Nevada (containing a device in Normal green status) and 
a location in California (containing a device in Critical red status). The images available in the list are determined by the 
administrator. 

The levels of the data center in location images can range from global maps to detailed images, depending on how the 
administrator decides to represent the data center network. By selecting a location image from the drop-down list and 
viewing the graphical status of device icons, you can quickly monitor and/or manage the data center devices available to 
you based on the level of your user permissions. 
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Using Current View to Monitor CDUs 

The Current View drop-down list on the Views page provides six different views of a CDU for any location image shown 
in the list on the left. For example, “Continental USA” is the location image and the current view is “Temperature”: 

 

The six current views are based on data measured and reported by the CDU for current status, load, power, temperature, 
humidity, and capacity. Although the views are fixed and cannot be configured on the Views page, the views offer a quick 
way to monitor the operating condition of a CDU.  

Each view you select displays its own legend. For example, if you select the “Temperature” view, the temperature value 
ranges and colors display for each icon on the location image: 

 

Based on the colored location icons and the matching color ranges in the Legend for the Temperature view, you can 
quickly determine the temperature of a CDU in a specific data center location.  

NOTE: Some CDUs do not support all types of data. For example, if temperature data is not available from the CDU to be measured and 
reported, the icon on the location image will be gray in the legend with the “N/A” label. 
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The following views provide CDU monitoring: 

CDU Current Views  

View Description 

Status Status of the CDU: Critical, Warning, Unreachable, Maintenance, or Normal. 

Load Load of the CDU (in amperes). 

Power Power reporting from the CDU (in watts). 

Temperature Temperature of the CDU (in degrees Celsius). 

Humidity Relative humidity of the CDU (in percentage). 

Capacity Power capacity used by the CDU (in percentage). 

Controlling the Page Layout 

For the administrator: The following buttons appear in a row at the top of the Views page to control displaying parent 
location, establishing home location, and moving icons around the location image: 

Views Page – Buttons  

Button Description 

 

Go to the parent of this location. From the displayed location image on the Views page, move up one level in the 
hierarchy of location images you configured for the data center.  

 

Edit/move icons. Move location, cabinet, and CDU icons around the displayed location image to position them as 
desired, and click Save or Cancel. 

 

Save layout changes. After positioning location, cabinet, and CDU icons on the displayed location image, to save 
your changes, click Save. 

 

Cancel layout changes. After positioning location, cabinet, and CDU icons on the displayed location image, to cancel 
your changes, click Cancel. 
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Introducing the Legends 

A unique legend displays at the bottom of the Views page in response to the current CDU view you selected. Legend  
colors and ranges are fixed and cannot be configured on the Views page. 

As a CDU reports its current operating status or other measurable conditions, the colors of the location, cabinet, and CDU 
icons change to match the color value ranges in the corresponding legend.  

By comparing an icon color to a color range in the legend, you can visually monitor a specific CDU in the data center. 

The Legend remains displayed until you select a different option from the Views drop-down list. Legends and color range 
values for the current CDU view are shown below.  

Status  

The colors in the Status legend show the current condition (status) of the CDU: 

 

Load  

The color range in the Load legend shows the load value used by the CDU (in amperes): 

 

Power  

The color range in the Power legend shows the reading of the CDU (in watts): 

 

Temperature  

The color range in the Temperature legend shows the temperature of the CDU (in degrees Celsius): 

 

Humidity  

The color range in the Humidity legend shows the humidity of the CDU (in percentage): 

 

Capacity 

The color range in the Capacity legend shows the power capacity used by the CDU (in percentage): 

 
 

NOTE: If a current view does not apply to a CDU, for example, humidity, the icon displayed on the Views page will be gray to correspond to the 
gray “N/A” label on the Humidity legend.  

The Icons Legend 
The Icons legend at the bottom of the Views page shows the shapes designated for location, cabinet, and CDU icons.     

 

The icon types are fixed and cannot be configured. To place icons on a location image, use the Configuration menu 
options for Locations, Cabinets, and CDUs. 
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Example of Current Views and Legends 

The following example shows the Status view selected from the drop-down menu and the coordinating Status legend 
displayed at the bottom of the page. The two icons indicate one location in Critical status (red) and the other location in 
Normal status (green). 

 

The following example shows the Humidity view selected from the drop-down menu and the coordinating Humidity 
legend displayed at the bottom of the page.  

The two icons changed color to represent their humidity condition, reflected in the value ranges in the Legend. One icon is 
within 31-50 % (green) and the other icon is within 0-10 % (blue). 

 

The Legend remains displayed until you select a different CDU view from the drop-down list.  

To identify an icon 

To quickly view the name and status of an icon, hover the mouse pointer over the icon.  
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Searching for a CDU  

The Search box is available in the left pane to search for a 
discovered device in the SPM network.  

 

 

Search is available by IP address, the CDU name (if 
different than IP address), enclosure, infeed, outlet, or 
environmental sensor.  

To start the search, click the down arrow and select the 
type of name from the drop-down list, such as CDU Name 
was selected in this example: 

 

 

As you start typing the name, a list of matches displays. 

 

 

Select a name in the list and click View Device. The detailed search results are displayed on a device details page. 
For example, for the CDU 66.214.208.132, you would see: 

 
  

NOTE: The default CDU name is IP address. The administrator can change the CDU name by using Config > CDUs > Configure CDUs.  
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Setting the Home Location  

On the Views page, do the following: 

1. To set a location image on the Views page as your home location, select the desired location from the Locations 
drop-down list on the Views page. 

2. Click the “Set this location as the home location” button on the Views page  .  

  The displayed image will remain as your home location, even after logging off. 

 3. To return to the Views page showing the image you set as you home location, click the Home View button in the 

     left pane . 

 

Displaying the Left Pane 

On the Views page, do one of the following: 

To collapse and hide the left pane of the SPM interface, click .  

To expand and display the left pane, click . 
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Building a Network Location 

For the administrator: SPM offers location, cabinet, and CDU icons to represent the levels of your data center. You can 
place icons for each level on location (background) images on the Views page. The way you customize these levels 
determines the hierarchy of your data center displayed on the Views page.  

NOTE: The administrator login has full access to all background images and icons that display on the Views page. The administrator must grant 
each user (or user group) access to individual location, cabinet, and CDU icons using Config > Users & Groups > Permissions. 

Working with Data Center Levels: Location, Cabinet, CDU 

Clicking an icon drills down to a lower data center level to show device operating details.  

The Location Level 

The location icon  on a background image represents a data center location, such as a city, state, place, building, floor, 
room, or other area specific to your site. The following example shows three location icons placed by the administrator on 
the image named Continental USA.  

 

Based on the Temperature view selected and the color ranges in the corresponding Temperature legend, the temperature 
ranges can be monitored for CDUs in the three locations. 
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To drill down from the Continental USA background image to the location named “California”, click the California icon 
to display the California background image: 

 

The above example shows the California location has a cabinet in Normal (green) status.  

Click the cabinet icon to drill down to the cabinet identification and operational details: 
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The Cabinet Level 

The cabinet icon  on a location image represents a specific cabinet in your data center. The following example shows 
a cabinet icon placed by the administrator on the data center location image named South Building: 

 

The Humidity view shows the cabinet, named 002_555, in Normal (green) status. To drill down to the operational details 
listed for the cabinet, click the cabinet icon. The Cabinet details page displays: 
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The CDU Level 

The CDU icon  on a background image represents a specific CDU in your data center. The following example shows a 
CDU named “66.214.208.134” placed by the administrator on the background image named South Building: 

 

The Capacity view shows the CDU, named 66.214.208.134, in the blue 0-40 capacity range. Click the CDU icon to 
drill down to the CDU details page that allows command control for the related outlets. 

 

The CDU details page displays the latest readings for individual outlet status, load, voltage, power, and control state. The 
page lets you monitor and control power to individual (or all) outlets.  

Outlets are sorted on the page by outlet name under the infeed and enclosure names of the CDU. You can control the 
outlets by issuing On, Off, and Reboot control commands on specific outlets or globally to all outlets in a CDU. For 
information about issuing commands, see CDU > Outlets on page 23. 
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Managing Networked CDUs   

The following options provide access to operational data for managing and controlling networked CDUs: 

CDU Menu Options  

Option  Description 

Manage  Displays information about CDU status (critical, warning, unreachable, normal, and maintenance) as 
 shown in the Status box, provides access to CDU details, and allows login to the Sentry firmware HTML 
 interface where CDU parameters can be configured. 

Infeeds  Displays the latest status, load, voltage, and power for the enclosures (towers) in the CDU; also shows 
 detailed operational parameters for the CDU and infeed details for a specific infeed.  

Outlets  Lets you issue outlet On, Off, and Reboot commands; displays the latest status, load, power, and  
 control  state for the outlets listed, and also shows detailed operational parameters for the CDU 

Environmental Monitors Lets you view networked environmental monitors by sensor name, temperature/humidity status, and 
 temperature/humidity percentage. 

Clusters  Reports total power usage (by cluster) for a CDU and provides operational details of cluster outlets 
 within the CDU.  

 

CDU > Manage  

The CDU > Manage option displays information about CDU status (critical, warning, unreachable, normal, and 
maintenance) as shown in the Status box, provides access to CDU details, and allows login to the Sentry firmware HTML 
interface where CDU parameters can be configured. 

 

Each tab represents one of the status categories (also shown in the Status box in the left pane) that contain reported CDUs 
requiring your attention and management. The number of CDUs in each category shows on the tab. Use the All tab for a 
quick display of all CDUs in a status category. 

Column Descriptions  

Column  Description 

Date/Time  Date and time the CDU was reported in the status category. 

Name  Name of the CDU (user-configured). Provides a link to the CDU > Outlets option for outlet commands. 

IP Address  IP address of the CDU. Provides a link to the Sentry firmware interface to configure CDU parameters. 

Reason  The first reported reason for the CDU status. For status details, click  . 

Location(Cabinet)  The parent location of the cabinet or CDU and the cabinet containing the CDU.  

NIC Serial Number The Network Interface Card (NIC) of the CDU. 

(Select checkbox)  When checked, allows you to set/remove a CDU from Maintenance Mode. 
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Using Maintenance Mode 

The CDU > Manage option controls CDUs in and out of Maintenance Mode. 

 

To move CDUs to Maintenance: 

1. Select CDU > Manage. 

2. Select the status category tab containing the CDU you want to move to Maintenance. 

3. Check the Select checkbox to the right of one or more CDUs. 

4. From the drop-down list, select the time period for the CDU(s) to remain in Maintenance Mode from the drop-
down list, for example “5 Minutes” as shown above. To keep the CDU in the Maintenance for an unspecified 
time, select the Indefinitely option. 

5. Click Set/Remove Maintenance Mode. The CDU(s) move to the Maintenance tab for the time period specified 
or until manually removed. 

To remove CDUs from Maintenance: 

1. Select CDU > Manage. 

2. Select the Maintenance tab. 

3. Check the Select checkbox to the right of one or more CDUs in Maintenance. 

4. Select the Remove option. 

5. Click Set/Remove Maintenance Mode. The CDU is removed from the Maintenance tab. 

NOTE: When a device is in Maintenance, all SPM communication to and from the device is stopped, notification to the user is stopped, and 
CDU readings are zero. After Maintenance status is finished, the device moves to Normal status, data for the device is retrieved again, and the 
actual status of the device will be determined. 

 

 

 

 



 

Sentry Power Manager Using Sentry Power Manager   23 
Operations Manual 

CDU > Infeeds 

The CDU > Infeeds option displays the latest status, load, voltage, and power for the enclosures (towers) in the CDU. 
Detailed operational parameters for the CDU also display on this page. 

 

To connect to the Sentry firmware, click the IP Address of the CDU.  

For more information about a specific infeed, click the infeed name to display the Infeed Details page: 

 
 

CDU > Outlets 

The CDU > Outlets option lets you issue outlet On, Off, and Reboot commands. The page displays the latest status, load, 
power, and control state for the outlets listed, and also shows detailed operational parameters for the CDU. 

 

The CDU details page displays the latest readings for individual outlet status, load, voltage, power, and control state. The 
page lets you monitor and control power to individual (or all) outlets.  

Outlets are sorted on the page by outlet name under the infeed and enclosure names of the CDU. You can control the 
outlets by issuing On, Off, and Reboot control commands on specific outlets or globally to all outlets in a CDU. For 
information about issuing commands, see CDU > Outlets on page 23. 
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Controlling Individual Outlets 

The CDU > Outlets option allows you to control specific outlets for a CDU by issuing On, Off, and Reboot commands. 

1. Select CDU > Outlets. 

2. Select a CDU from the drop-down list.   

3. For a single outlet (or multiple outlets) in the CDU, select a command from the Control Action drop-down list, as 
shown: 

   

4. Click Apply Outlet Control.  

NOTE: The level of your user access rights determines the available outlet commands. 

Controlling All Outlets 

The CDU > Outlets option allows you to control all outlets for a CDU by issuing On, Off, and Reboot commands. 

1. Select CDU > Outlets. 

2. Select a CDU from the drop-down list.   

3. For all outlets in a CDU, select a command from the Set All Outlets To drop-down list, as shown: 

   

4. Click Apply Outlet Control.  

NOTE: The level of your user access rights determines the available outlet commands. 

 

Outlet Details 

The CDU > Outlets option gives access to details about each outlet displayed. 

1. Select CDU > Outlets. 

2. Click an outlet name. 
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              The Outlet Details page displays: 

              

 

Accessing the Sentry Firmware 

The CDU > Outlets option gives access to the Sentry firmware interface where you configure CDU parameters. 

NOTE: You must know the local user account login to access the Sentry firmware. 

1. Select CDU > Outlets. 

2. Select a CDU from the drop-down list. 

3. Click the IP Address link of the CDU: 

   

  The Login page for the Sentry firmware interface displays: 

                

4. Log in using your local user account. 

5. Configure CDU parameters as necessary. For more information about the firmware interface, refer to the 
Installation and Operations manual for your Sentry product located at www.servertech.com/support. 

http://www.servertech.com/support�
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CDU > Environmental Monitors  

The CDU > Environmental Monitors option shows the latest reported temperature, humidity, and sensor data about 
environmental monitors and sensors associated with a specific CDU. The page also shows detailed operational parameters 
for the CDU. 

 

The names of the environmental monitors and related sensors display on the page in a list sorted by sensor name under 
monitor name. Current values for the sensor status, temperature, and relative humidity are reported from the devices.  

To monitor the values of another environmental monitor, select a different CDU from the drop-down list. 

 

CDU > Clusters  

The CDU > Clusters option shows the latest status, load, power, capacity, and control state for the outlets the 
administrator has associated with a specific cluster. The page also provides the On, Off, and Reboot commands that you 
can issue on all outlets within the cluster. 

 
The page gives links to additional information about outlets and CDU systems: 

  To display operational details for an outlet, click Outlet Name. 

  To display operational details for a CDU, click System Name. 

  To connect to the Sentry firmware, click System IP Address. 

  To display a different cluster, select the cluster name from the drop-down list.  
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About Clusters and Groups 

The administrator selects the outlets to be collected under a specific group or cluster at Config > Clusters.  

An outlet group is a collection of outlets in a CDU system (up to two linked enclosures) with a single IP address.  

An outlet cluster is a collection of outlets across multiple CDU systems with multiple IP addresses.  

On the CDU > Clusters page, the name in the drop-down list may be a group or cluster, depending on whether the 
administrator configures a single IP address (group) or configures multiple IP addresses (cluster). 

Controlling All Outlets in Groups/Clusters 

The CDU > Clusters option allows you to control all outlets within an outlet group (or cluster) by issuing On, Off, and 
Reboot commands. 

1. Select CDU > Clusters. 

2. Select a cluster name from the drop-down list.   

3. For all outlets in the cluster, select a command from the Set All Outlets To drop-down list, as shown: 

   

4. Click Apply Outlet Control.  

NOTE: The level of your user access rights determines the available outlet commands. 

 

Generating Reports and Logs  

The Reports menu provides a variety of general data reports, graphical trend reports, and system activity logs. Report 
formats are HTML, XML, Microsoft Word, or Microsoft Excel. You can view reports and logs online or in print and most 
logs can be configured for Email alert. 

The following options are available on the Reports menu: 

Reports Menu Options  

Option  Description 

General Reports    Generates several hardware-based CDU reports for inventory, voltage, power, and environment;  
   reports are produced by location, cabinet, and combined location/cabinet. For the administrator:,  
   POPS reports are also available for energy consumption (by timeframe) and energy utilization (by  
   usage parameters).  

Trends    Generates a graphic report on specific variables from CDU readings over a specified      
   time frame as applicable data is available to be reported. Trend report choices are temperature,   
   humidity, infeed/outlet load, infeed/outlet power, power density, and system total power. 

Logs    Branches to options for detailed system activity logs: Discovery, User Login, Use Actions, Alarm   
   Status, and Combined (combines all system activity into one report). The logs (with the exception of  
   the Combined log), can be configured for Email alert.  

NOTE: To print a report, use the Print function of your browser. 

General Reports 

The Reports > Reports option collects data from CDU readings and generates several general reports for inventory, input 
voltage, input power, total power, power density, environment, and cluster power. Note that only available data from CDU 
readings for the report type, location, and grouping you select will be reported.   
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General Reports - Examples 

The following example shows an inventory report generated for all locations:  

 

 

The following example shows a detailed power report for all clusters: 

 

 

The following example shows an input voltage report grouped by cabinet: 
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Generating a Report: 

Depending on the Report Type you choose (for example, Inventory), only the networked CDUs that have measured 
readings will be reported. The report will be based on the location and grouping you select. 

 

To generate a report: 

1. Select the type of report (inventory, input voltage, input power, total power, power density, environment, and 
cluster power) from the Report Type drop-down list.  

2. Select the desired location(s) to report on from the Location drop-down list as follows: 

  To select a block of adjacent locations, click the first location in the block, press the Shift key, and click the  
        last location in the block.  

  To select non-adjacent locations, click the first location, press the Ctrl key, and click  
  each additional location.  

3. Select how the report will be grouped (by location, cabinet, location/cabinet, or no grouping) from the Group By 
drop-down list. Cluster reports cannot be grouped and are reported by selected cluster name(s). 

4. Select how the report will be formatted (HTML, XML, Microsoft Word, or Microsoft Excel) from the Format 
drop-down list. 

5. Click Generate Report to display the report. 

6. To print a report, use the Print function of your browser. 

 

POPS Reports 

For the administrator: For networks with Per Outlet Power Sensing (POPS) units, reports are available at the Reports > 
Reports option to show energy value readings for consumption and usage, based on individual outlets, devices, 
groups/clusters, or the entire data center. For more information about the POPS feature, see www.servertech.com 

Two types of POPS reports are available: 

  Energy Consumption: Produces total energy consumption reports for outlet and infeed billing levels. Reports are   
  available by location, cabinet, CDU, and outlet group/cluster. You can generate a total energy billing report by day,   
  month, or year based on infeed or outlet data for the reporting period.  

  Energy Utilization: Produces reports from energy value readings to measure and evaluate CDU and group/cluster   
  outlet energy usage and efficiency. Reports are available by location, reading, CDU, group/cluster, and specified 
     timeframe. 

http://www.servertech.com/�
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POPS Energy Consumption Report – Example 

The following POPS example shows energy consumed on the outlet billing level for detailed CDUs at all locations: 

 

NOTE: The detailed CDU report includes the Detail column of outlet names. 

POPS Energy Utilization Report – Example  

The following POPS example shows low energy used on outlets for all CDU readings:  
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Generating a POPS Report 

From the Reports > Reports option, the administrator accesses POPS report options from the Report Type drop-down list. 
POPS reports options are listed under the categories Energy Consumed and Energy Utilization as shown: 

                 

NOTE: POPS report options are displayed for administrator login accounts only. 

To generate a POPS report: 

1. Select the type of POPS report (Energy Consumed – by day, month, or year) or Energy Utilization (high, low, or 
no usage) from the Report Type drop-down list. The Report Parameters box displays with parameters specific to 
the type of POPS report you requested: 

   

2. Select the desired options from the drop-down lists, such as Subtype or Billing Level, Report On, and Location. 
Multiple locations can be selected from the Location drop-down list as follows: 

  To select a block of adjacent locations, click the first location in the block, press the Shift key, and click the 
         last location in the block.  

  To select non-adjacent locations, click the first location, press the Ctrl key, and click each additional location.  



 

32   Using Sentry Power Manager  Sentry Power Manager  
                                                                          Operations Manual 

3. Click in the Start Date and End Date fields to select the trend report timeframe from the pop-up calendar. 

4. Select how the report will be formatted (HTML, XML, Microsoft Word, or Microsoft Excel) from the Format 
drop-down list. 

5. Click Generate Report to display the report. 

6. To print a report, use the Print function on your browser. 

Trend Reports 

The Reports > Trends option uses data collected from CDU readings and converts the data into graphic charts based on 
the requested time frame. You can generate a trend report for several parameters during a specified time period, however, 
only available data from CDU readings for the designated parameter and time frame you select will be reported.   

Trend Report Samples 

The following example shows a Trend report generated over a specified time range for the historic reporting of variations 
in temperature for the selected sensors.  

 



 

Sentry Power Manager Using Sentry Power Manager   33 
Operations Manual 

The following example shows a Trend report generated over a specified time range for the historic reporting of variations 
with infeed power for the selected infeed names.  

 

 

Generating a Trend Report 

Depending on the Trend Type you choose (for example, Temperature), only the networked sensors that have measured 
readings from the CDU for temperature will be collected and displayed in the Sensors list box, as shown below.  

The trend report will be based on the sensors you select.  

 

To generate a trend report: 

1. Select the type of report (temperature, humidity, outlet load, outlet power, infeed load, infeed power, power 
density, or system total power) from the Trend Type drop-down list.  

  Based on the Trend Type, the parameters with data readings appear in the related list box. 
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2. Select parameters from the list box as follows:  

  To select a block of adjacent parameters, click the first item in the block, press and hold down the  
  Shift key, and click the last parameter in the block.  

  To select non-adjacent parameters, click the first item, press and hold down the Ctrl key, and click  
  each additional parameter.  

3. Click in the Start Date and End Date fields to select the trend report timeframe from the pop-up calendar. 

4. Click Generate Trend to display the graphic trend report. 

5. To print a trend report, use the Print function of your browser. 

NOTE: The longer the timeframe requested for the trend report, the less detail will be available for reporting. In addition, some parameters you 
select for the trend report may not have available data as measured by the CDU for the specified timeframe, and those parameters will not be 
displayed on the trend report.  

Logs  

The Reports > Logs option provides access to specific system activity logs (Discovery, User Login, User Actions, Alarm 
Status, and Combined). The Combined log shows all SPM system activity combined into a single report. 

 Discovery Log 

The Reports > Logs > Discovery option lists the events that occur during the discovery of CDUs in the network by Sentry 
Power Manager. The most current discovery activity displays first. 

 

The Discovery log shows the default “System” User Name, IP Address (blank for discovery), Event Time, and a detailed 
description of the discovery event, such as “Discovery process completed for IP 10.1.2.137 though IP 10.1.2.137”.  

Working with the Discovery Log 

 To change the date range, click Start Date and End Date for a popup calendar. 

 To sort the log data by a column heading, click the desired column heading (arranges data in ascending order by the 
heading), or click again (arranges data in descending order by the heading).  

 The Discovery Log is available for delivery by Email alert.   

 To print a report, use the Print function on your browser. 

Clearing the Log  

For the administrator: To delete log data permanently, click Clear Log.  
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User Login 

The Reports > Logs > User Login option shows all login attempts to SPM. The log is generated by the date range 
specified, and the most current user login activity displays first. 

 

The User Login displays the user name, user’s IP address, time of login attempt, and a Description of user login or logout. 

Working with the User Login  

 To change the date range, click Start Date and End Date for a popup calendar. 

 To sort the log data by a column heading, click the desired column heading (arranges data in ascending order by the 
heading), or click again (arranges data in descending order by the heading).  

 The User Login is available for delivery by Email alert.  

 To print a report, use the Print function on your browser. 

Clearing the Log  

 For the administrator: To delete log data permanently, click Clear Log.  
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 User Actions 

The Reports > Logs > User Actions option displays system activity details by specific username.  

 

The most current activity displays first, showing chronological system activity. The User Actions log shows user name, IP 
address, time of system activity, and a description of the activity.  

Working with the User Actions Log 

 To change the date range, click Start Date and End Date for a popup calendar. 

 To sort the log data by a column heading, click the desired column heading (arranges data in ascending order by the 
heading), or click again (arranges data in descending order by the heading).  

 The User Actions Log is available for delivery by Email alert.   

 To print a report, use the Print function on your browser. 

Clearing the Log  

 For the administrator: To delete log data permanently, click Clear Log.  
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Alarm Status 

The Reports > Logs > Alarm Status option provides system polling details about the changes in operational status of a 
CDU. The status of a CDU is one of the predetermined categories: Critical, Warning, Unreachable, Normal, and 
Maintenance. The most current reporting activity displays first. 

 

The Alarm Status log shows user name, IP address of the affected CDU, time of system event, and a description of the 
status activity.  

Working with the Alarm Status Log 

 To change the date range, click Start Date and End Date for a popup calendar. 

 To sort the log data by a column heading, click the desired column heading (arranges data in ascending order by the 
heading), or click again (arranges data in descending order by the heading).  

 The Alarm Status Log is available for delivery by Email alert.   

 To print a report, use the Print function on your browser. 

Clearing the Log  

 For the administrator: To delete log data permanently, click Clear Log.  
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Combined 

The Reports > Logs > Combined option is a combination of all system activities as reported by the individual Discovery, 
User Login, User Actions, and Alarm Status logs. 

 

The Combined log shows User Name, IP address, the time of the recorded system event, and a detailed description of the 
event. The most current activity displays first. 

Working with the Combined Log 

 To change the date range, click Start Date and End Date for a popup calendar. 

 To sort the log data by a column heading, click the desired column heading (arranges data in ascending order by the 
heading), or click again (arranges data in descending order by the heading).  

 To print a report, use the Print function on your browser 

Clearing the Log  

 For the administrator: To delete log data permanently, click Clear Log.  
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Configuring Sentry Power Manager 

For the administrator: The Configuration menu provides the options necessary for configuring the control settings of 
SPM. The settings configured in SPM specifically for the CDU (names of enclosures, infeeds, and outlets, as well as 
infeed/outlet load thresholds) are downloaded directly (“pushed down”) from SPM to the CDU.  

The following options are available for the administrator on the Config menu: 

Config Menu Options  

Option  Description 

Locations  Configures and manages default and custom location images (used as the background on the Views page) 
 where the administrator places icons for data center locations, cabinets, and CDUs. 

Cabinets  Adds, edits, and deletes cabinets; specifies cabinet area (in square ft.) for optional calculation of power 
 density; includes entry of optional actual/theoretical capacities, and associates a cabinet with a location. 

CDUs  Branches to options for specific CDU administrative tasks: CDU discovery, configuration  of CDU parameters, 
 and the editing of environmental monitors, sensors, temperature/humidity thresholds, enclosures, infeeds, 
 and outlets; associates a CDU with a cabinet/location. 

Clusters  Structures the data center by allowing the administrator to select CDU power outlets and place them into a 
 collection of named “groups” or “clusters” for faster administration. 

Users & Groups  Allows administration of individual user names and passwords, associates user with a specific user group, 
 and determines user access rights to clusters, locations, cabinets, CDUs, and outlets; and configures LDAP 
 parameters. 

Settings  Allows configuration of SPM network access parameters for email alerts, system, network, web, Telnet, serial 
 connection, and connection to the SPM database connection.  

NOTE: The administrator login has full access to all background images and icons that display on the Views page. The administrator must grant 
each user (or user group) access to individual location, cabinet, and CDU icons using Config > Users & Groups > Permissions. 

Config > Locations  

The Config > Locations option allows the administrator to configure and manage default and custom (location) images 
which are displayed on the Views page as the background for location, cabinet, and CDU icons. 

 

Location images include default maps installed with SPM and any custom images the administrator uploads to SPM.  

The administrator configures default and custom images (to provide the working backgrounds displayed on the Views 
page) and places icons on the images to represent actual data center locations, cabinets, and CDUs.  

Acceptable graphic file formats for location images are JPG, PNG, and GIF. The recommended width of the image is less 
than 800 pixels wide.  
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Adding a New Location Image 

1. Select Config > Locations. 

2. Click Add New Location to display the following box: 

   

3. (Required) Type a Location Name for the location image. 

4. (Required) Click Browse to locate the graphics file for the location image. 

5. (Optional) Select a Parent location image. Default is None. 

6. (Optional) Type a numeric value in the Actual Capacity field. Actual Capacity is a user-defined value to show 
the maximum capacity of the sum of the infeed circuits; for example, 2 x L630P – 208V * 30A*2 = 12,480W.  

7. (Optional) Type a numeric value in the Theoretical Capacity field. Theoretical Capacity is a user-defined value 
to show the desired “safety rating” of the sum of the infeed circuits, 20% in this example: 2 x L630P – 
208V*30A*2*.8 = 9,984W. 

8. Click Add New Location. The message Operation Succeeded displays and the new image is added by name to 
the drop-down location list on the Views page.  

    The image is also added to the Config > Locations option and shows a checkmark in the Enabled checkbox: 

     

Disabling a Location Image 

1. Select Config > Locations. 

2. Uncheck the Enabled checkbox next to the image name(s) you want to disable and click Apply Changes. The 
disabled image remains in SPM (to be enabled later, if desired) but the image does not appear in the location 
drop-down list on the Views Page. 

Enabling a Location Image 

1. Select Config > Locations. 

2. Check the Enabled checkbox next to the image name(s) you want to enable, and click Apply Changes. The 
enabled image appears in the location drop-down list on the Views Page.  
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Editing a Location Image Name 

1. Select Config > Locations. 

2. Type over the name of the image(s) in the Name field and click Apply Changes. The edited image name appears 
in the drop-down list on the Views Page.  

Viewing a Location Image Thumbnail 

1. Select Config > Locations. 

2. Click the View button to the right of an image name to see a thumbnail version.  

Deleting a Location Image 

1. Select Config > Locations. 

2. Check the Delete checkbox to the far right of the image name you want to delete and click Apply Changes. The 
image is permanently removed from SPM. 

NOTE: Only empty background images can be deleted. If a background image contains at least one location, cabinet, or CDU, the Delete 
checkbox will not display on the Config > Locations page. 

Changing a Parent Location Image 

1. Select Config > Locations. 

2. For the desired image name, select a different parent location image from the Parent drop-down list.  

3. Click Apply Changes. The image name is associated with the new parent location image. 
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Config > Cabinets 

The Config > Cabinets option allows the administrator to configure and manage data center cabinets. 

 

The Config > Cabinets option allows the adding, editing, and deleting of cabinets. In addition, cabinets can be associated 
with parent location images. When a cabinet is added and associated with a location, the cabinet appears as a cabinet icon 
on the Views page.  

The area of the cabinet (for the calculation of total system watts) and capacity planning data for the cabinet (actual 
capacity/theoretical capacity) are optional values for cabinet configuration. 

Adding a New Cabinet 

1. Select Config > Cabinets. 

2. Click Add New Cabinet to display the following box: 

   

3. (Required) In the Cabinet Name field, type a name for the new cabinet. 

4. From the Parent drop-down list, select a parent location image to be associated with the cabinet. Default is None.  

NOTE: The None option in the Parent drop-down list disassociates the cabinet from all location images (the cabinet does not appear 
on the Views page) but keeps the cabinet available in SPM.   

5. (Optional) In the Area field, type a numeric value (in square ft.). Use whole numbers only – no fractions.  

6. (Optional). Type a numeric value in the Actual Capacity field. The Actual Capacity field is a user-defined value 
to show the maximum capacity of the sum of the infeed circuits; for example, 2 x  L630P – 208V * 30A*2 = 
12,480W. 

7. (Optional). Type a numeric value in the Theoretical Capacity field. The Theoretical Capacity field is a User-
defined value to show the desired “safety rating” of the sum of the infeed circuits, 20% in this example: 2 x 
L630P – 208V*30A*2*.8 = 9,984W. 

8. Click Add New Cabinet. The message Operation Succeeded displays and the new cabinet is added by name to 
the parent location image on the Views page.  

    The image is also added to the Config > Cabinets page: 
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Editing a Cabinet  

1. Select Config > Cabinets. 

2. For one or more cabinets, type over the Name, Area, Actual Capacity, and Theoretical Capacity fields, and select 
a different parent location image from the Parent drop-down list, as desired.  

NOTE: The Area field is sq. ft. and must be a whole number.   

3. Click Apply Changes. The edits to the cabinet(s) are applied throughout SPM.  

Deleting a Cabinet  

1. Select Config > Cabinets. 

2. For one or more cabinets shown on the list, check the Delete checkbox.  

3. Click Apply Changes. The cabinets are removed from SPM. 

NOTE: Only empty cabinets can be deleted. If a cabinet contains one or more CDUs, the Delete checkbox will not display on the 
Config > Cabinets page.  

Config > CDUs 

The Config > CDUs option branches to additional options for CDU administrative tasks: discovery of CDUs, adding and 
configuring CDUs, and configuring environmental monitors, sensors, enclosures, and outlets. 

Discover CDUs 

The Config > CDUs > Discover CDUs option allows the administrator to define parameters for CDU manual discovery as 
SPM searches by IP address for SNMP-enabled CDUs. The Discover option also allows editing of SNMP GET/SET 
community string and FTP login.  

 

Use the Discovery feature for the initial discovery of CDUs when SPM is installed, and then to discover new CDUs as 
they are installed in the network.  

Discovered CDUs communicate with SPM to report alarms and CDU status changes to assist in the global management of 
your data center network.  

The Discovery feature can discover a single CDU by exact IP address or multiple CDUs in a range of IP addresses. 

NOTE: The CDU Discovery is executed immediately upon request and cannot be scheduled. 

About the FTP Fields 

SPM uses the FTP configuration of the CDU to obtain CDU group information for discovery. Therefore, the FTP User 
Name and FTP Password fields – which are the valid administrative user name/password for direct access of the CDU 
through the Sentry firmware interface – are also required fields for SPM discovery.  
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Discovering a Single CDU 

1. Select Config > CDUs > Discover CDUs. 

2. Type the Discovery Starting IP Address in the field provided. Be sure to type an IP address, not a hostname. 

3. In the Discovery Ending IP Address field, type the last node of the starting IP address. For example, if the 
starting IP address typed was 10.1.1.74, then type “74” in the Discovery Ending IP Address field. The previous 
nodes are auto-filled. The Discovery feature will search, discover, and connect only the one CDU specifically 
named 10.1.1.74. 

4. Type the SNMP community string from the SNMP settings on the CDU in the network. The community string is 
used during the discovery process. 

5. In the FTP User Name and FTP Password fields, type the valid administrative user name and password used for 
direct access of the CDU through the Sentry firmware interface. The FTP fields must be different than your 
administrative login user name/password for SPM. 

6. Click Initiate CDU Discovery to perform an immediate discovery on the single CDU requested.  

Discovering Multiple CDUs 

1. Select Config > CDUs > Discover CDUs. 

2. Type the Discovery Starting IP Address in the box provided. Be sure to type an IP address, not a hostname. 

3. In the Discovery Ending IP Address field, type the IP address of the last CDU you want discovered. For 
example, if the starting IP address typed was 10.1.1.74, and the Discovery Ending IP Address field is 10.1.1.125,  
the Discovery feature will search, discover, and connect to all valid CDUs in the range between the IP addresses 
10.1.1.74 and 10.1.125. 

4. Type the SNMP community string from the SNMP settings on the CDU in the network. The community string is 
used during the discovery process.  

5. In the FTP User Name and FTP Password fields, type the valid administrative user name and password you use 
for direct access of the CDU through the Sentry firmware interface. The FTP fields must be different than your 
administrative login user name/password for SPM. 

6. Click Initiate CDU Discovery to perform an immediate discovery on the range of CDUs requested.  
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Configure CDUs 

The Config > CDUs > Configure CDUs option allows the administrator to manage individual CDUs in the SPM network 
and configure detailed operational parameters for the CDU. 

 

The Configure CDUs page lists the current settings of discovered CDUs and shows the associated cabinet or location 
image. The settings on this page are downloaded directly (“pushed down”) from SPM to the CDU. 

To Add a CDU 

The Add New CDU function allows the administration to add one discovered CDU at a time (by exact IP address) to the 
SPM device network. The Add New CDU function works the same way as the Discover CDUs function, but only for a 
single CDU at a time, providing a quick way to add one CDU to the network after bulk discovery. 

1. Select Config > CDUs > Configure CDUs. 

2. Click Add New CDU to display the following box: 

   

3. Provide the IP Address, SNMP Get/Set parameters, FTP username/password, and click Add New CDU.  
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To Configure CDU Parameters 

1. Select Config > CDUs > Configure CDUs. 

2. For one or more CDUs, edit the CDU Name, SNMP Get/Set parameters, CDU capacity (numeric watts value), 
and the cabinet/location associated with the CDU. 

3. Click Apply Changes. 

To Delete a CDU  

1. Select Config > CDUs > Configure CDUs. 

2. For one or more CDUs shown in the list, check the Delete checkbox.  

3. Click Apply Changes. The CDUs are removed from SPM. 

 Environmental Monitors 

The Config > CDUs > Environmental Monitors option lets the administrator edit the names of environmental monitors 
and sensors, and set the sensor high/low thresholds for temperature/humidity. 

  

High/low sensor temperature thresholds are measured in degrees Celsius. High/low sensor humidity thresholds are 
measured in percentage. 

To Configure Environmental Monitor Name, Sensor Name, and Sensor Values 

1. Select Config > CDUs > Environment Monitors. 

2. For one or more Environmental Monitors shown on the list, edit the environmental monitor name, sensor name, 
temperature values, and humidity values as necessary. 

3. Click Apply Changes. 
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Enclosures  

The Config > CDUs > Enclosures option allows the administrator to edit the names of CDU components: enclosures, 
infeeds, and outlets; also allows configuration of load threshold (in amperes) and low/high power limits (in watts). 

 

An enclosure is a Sentry unit (made up of infeeds and outlets) that is part of an overall Sentry CDU. In the example above, 
the Sentry Switched 66.214.208.91 is made up of the following units: 

  A Switched master unit named cdu20046.a, which is the first enclosure with an infeed named TowerA_InfeedA.  
TowerA_InfeedA has eight related outlets, starting with Exchange_Server1 and so on. 

 A Switched extension unit named cdu20046.b, which is the second enclosure with an infeed named TowerB_InfeedA. 
TowerB_InfeedA has several related outlets, starting with TowerB_Outlet1 and so on. 

Both the master and extension units (cdu20046.a and cdu20046.b) are two separate enclosures in the single Sentry CDU 
system named 66.214.208.93. 

To Configure Enclosure Settings: 

1. Select a CDU from the drop-down list. 

2. Edit the names of one or more enclosures, infeeds, and outlets, and change outlet load values (in amperes) and 
high/low power limits (in watts), as necessary. 

3. Click Apply Changes.  
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Config > Clusters 

The Config > Clusters option allows the administrator to structure the data center for fast control of outlets by configuring 
collections of CDU power outlets into named clusters (or groups) for remote reboot and power information. Outlets are 
selected and associated with an outlet cluster (or group).  

 

An outlet group is a collection of outlets on a CDU system (up to two linked enclosures) with a single IP address.  

An outlet cluster is a collection of outlets across multiple CDU systems with multiple IP addresses.  

NOTE: The Type field is determined by the outlet configuration of the CDU, either “Group” or “Cluster” depending on the configuration of 
physical outlets in the CDU – either a single IP address (Group), or multiple IP addresses (Cluster). 

 

Add a Cluster 

1. Select Config > Clusters. 

2. Click Add New Cluster to display the following box: 

   

3. Type the new cluster name and click Add New Cluster. The Clusters page displays showing the new name: 

                 

NOTE: The Type field on the Clusters page is determined by the outlet configuration of the CDU, either “Group” or “Cluster” 
depending on the configuration of physical outlets in the CDU – either a single IP address (Group), or multiple IP addresses (Cluster). 

 



 

Sentry Power Manager Using Sentry Power Manager   49 
Operations Manual 

4. For the new name, click Select Outlets to display the following box: 

                

5. Determine the filter by selecting an option from the Filter By drop-down list in the upper left corner of the box, 
for example, “CDU”, which provides an additional drop-down list for selecting the desired CDU.  

                

6. For the “CDU” option, all outlets in the selected CDU display in the Select Outlets box. Check the Enabled 
checkbox for each outlet you want to be within the new cluster: 

                

7. Click Apply Changes. The selected outlets are associated with the new cluster name. 
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8. Select the CDU > Clusters option, and from the displayed window, select the new cluster name from the drop-
down list in the upper left corner:   

   
 The selected outlets for the new cluster are listed, and the window provides the following links: 

 To issue On, Off, and Reboot commands for an outlet, click the System Name. 

 To access the Sentry firmware login, click the System IP Address. 

 To display operating details for an outlet, click the Outlet Name. 

Edit a Cluster 
1. Select Config > Clusters. 

2. Type over the group or cluster name in the Name field and click Apply Changes. The edited name appears on 
the drop-down list on the CDU > Clusters page, and all outlets are associated with the edited name.  

Delete a Cluster 

1. Select Config > Clusters. 

2. Check the Delete checkbox to the right of one or more groups or clusters listed. 

3. Click Apply Changes. All outlets remain in SPM but are deleted from the cluster name. 
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Config > Users & Groups  

The Config > Users & Groups option allows the administrator to configure and maintain the parameters of SPM users 
and user groups. Multiple SPM users can be logged in concurrently. 

User types are the predefined levels of access rights to SPM as granted by the administrator to individual users in named 
user groups. The following user types are recognized by SPM: 

User Types 

Type Description 

Admin Administrative. Full access for all configuration, control (On, Off, Reboot), status, and serial/pass-thru ports. The 
SPM default administrative user is the admn user account. (Note there is no “i” in the admn name/password.) The 
admn user may grant full administrative access level rights to other users. See Note below. 

Regular User Partial access for control (On, Off, Reboot), status, and pass-thru of assigned outlets, groups, clusters, and 
serial/pass-thru ports. 

View Only Partial access for status and pass-thru of assigned outlets, groups, clusters, and serial/pass-thru ports. 

Reboot Only Partial access for control (Reboot), status, and pass-thru of assigned outlets, groups, clusters, and serial/pass-thru 
ports. 

NOTE: For security it is recommended that you first use the default admn user account to grant access rights to another administrative user 
account. Use the new administrative account to then change the default admn account username/password. Note that the admn account cannot be 
deleted or demoted. 

Configuring Users 

The Config > Users & Groups > Users option allows maintenance of users, user passwords, and user group assignments.    

 

To add a new user: 

1. Select Config > Users & Groups > Users 

2. Click Add New User. 

3. Type the new username, password, password confirmation, and select a user group from the drop-down menu. 
Password is case-sensitive; strong passwords are supported by SPM but are not required. 

4. Click Add/Change. The new user is added... 

To change a username: 

1. Select Config > Users & Groups > Users. 

2. Type over the user’s name in the Name field. 

3. Click Apply Changes. The user name is changed. 

To change a user’s password: 

1. Select Config > Users & Groups > Users 

2. Enter the new password in the Password column next to the name of the user. Password is case-sensitive. 

3. Click Apply Changes. The user’s password is changed. 
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To change a user’s group: 

1. Select Config > Users & Groups >Users. 

2. From the drop-down list next to the user’s name, select a different user group.  

3. Click Apply Changes. The user group association is changed. 

To delete a user: 

1. Select Config > Users & Groups > Users. 

2. Check the Delete checkbox next to the user’s name you want to delete. 

3. Click Apply Changes. The user is deleted from SPM. 
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Configuring User Groups 

The Config > Users & Groups > User Groups option allows the administrator to assign a user type (Regular, 
Administrator, View, and Reboot) to named user groups that contain individual SPM users. 

 

The User Groups page allows maintenance of user group names and the association of user groups to a specific user type. 
User types are the levels of access rights to SPM. User types are predefined and cannot be changed.  

To Add a New User Group: 

1. Select Config > Users & Groups > User Groups. 

2. Click Add New User Group to display the following box: 

   

3. Type the new user Group Name and select the user Type from the drop-down list. 

4. Click Add New User Group. The new user group (with the associated user type) is added. 

To Change a User Group Name: 

1. Select Config > Users & Groups > User Groups. 

2. Edit the name in the Group Name field. 

3. Click Apply Changes. The user group name is changed. Note that user type is not affected. 

To Delete a User Group: 

1. Select Config > Users & Groups > User Groups. 

2. Check the Delete checkbox next to the user group you want to delete. 

3. Click Apply Changes. The user group is removed from SPM. 

To Change a User Type: 

1. Select Config > Users & Groups > User Groups. 

2. From the Type drop-down list next to the user group name, select a different user type. 

3. Click Apply Changes. The user group is associated with the new user type. 

NOTE: Only empty user groups can be deleted. If a user group contains one or more users, the group cannot be deleted until the users are deleted 
or moved to another user group. 
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Configuring LDAP 

The Config > Users & Groups > LDAP option allows the administrator to assign a user type (Regular, Administrator, 
View, and Reboot) to named LDAP user groups that contain individual SPM LDAP users. 

 

The LDAP support enables authentication with LDAP servers so that user accounts do not need to be individually created 
locally on each Sentry CDU.  

SPM administrators can pre-define and configure – in each Sentry product and in the LDAP server – a set of necessary 
LDAP groups, and access rights for each group.  

The user’s access rights can then be granted or denied simply by making the user a member of one or more pre-defined 
Sentry LDAP Groups. User accounts can be added, deleted, or changed in the LDAP server without any changes needed 
on individual Sentry CDUs. 

Sentry CDU support for LDAP has been tested in the following environments: 

 Microsoft Active Directory (MSAD) 
 Novell eDirectory (eDir) 

To add a new LDAP user group: 

1. Select Config > Users & Groups > LDAP. 

2. Click Add New LDAP User Group to display the following box: 

   

3. Type the new LDAP user group name and select a user group association from the drop-down menu. 

4. Click Add New LDAP User Groups. The new LDAP user group is added. 

To change an LDAP user group name: 

1. Select Config > Users & Groups > LDAP. 

2. Type over the LDAP user group name in the Name field. 

3. Click Apply Changes. The LDAP user group name is changed. 

To delete an LDAP user group: 

1. Select Config > Users & Groups > LDAP. 

2. Check the Delete checkbox next to the LDAP user group name you want to delete. 

3. Click Apply Changes.  

To change an LDAP user group association: 

1. Select Config > Users & Groups > LDAP. 

2. From the User Group drop-down list next to the LDAP name, select a different user group.  

3. Click Apply Changes. The user group associated with the LDAP group is changed. 
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To configure LDAP: 

1. Select Config > Users & Groups > LDAP. 

2. Click Configure LDAP to display the following box: 

  

3. Select Enabled or Disabled from the LDAP drop-down list.   

4. Type the IP addresses (or hostnames) in the Primary and/or Secondary Host fields. 

5. Type the server port number in the Port field. 

6. Select Yes or No from the Use TLS/SSL drop-down list.  

NOTE: If LDAP over TLS/SSL is enabled, MD5 binding is disabled. 

7. Select Simple or MD5 from the Bind Type drop-down list.  

NOTE: If MD5 binding is enabled, LDAP over TLS/SSL is disabled. 

8. Type the fully-qualified distinguished name (FQDN) in the Search Bind DN field. 

9. Type the Search Bind Password in the Search Bind Password field. 

10. Type the User Search Base DN in the User Search Base DN field. 

11. Type the User Search Filter in the User Search Filter field. 

12. Type the group membership attribute in the Group Membership Attribute field. 

13. Select DN or Name from the Group Membership Attribute drop-down list. 

14. Select Remote->Local or Remote Only from the drop-down list. 

NOTE: Server Technology recommends NOT setting the authentication order to Remote Only until the LDAP has been fully 
configured and tested.   

15. Click Apply Changes. 
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Configuring Permissions  

The Config > Users & Groups > Permissions option allows the administrator to grant or deny user group permission to 
locations, clusters, cabinets, CDUs and outlets. 

 

The Group Permissions page shows a column for each user group and a row for each object currently selected. The 
administrator grants or denies permission by user group only, not by individual user.  

To grant or deny user group permissions to SPM devices 

1. Select Config > Users & Groups > Permissions. 

2. Select an item in the SPM network from the drop-down list, such as Outlets. SPM outlet names display in the 
Object field. 

3. Check (to grant) or uncheck (to deny) the checkboxes under specific user group names for each object listed. 

4. Click Apply Changes. User group permissions are updated. 
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Config > Settings 

The Config > Settings option allows the administrator to set up SPM as an appliance, eliminating the need to configure 
these settings through the operating system. Standard default port numbers are provided or designated port numbers within 
the network firewall can be used. 

Email 

The Email option configures the email delivery of requested SPM system activity logs to a primary and/or secondary 
email address. 

 

As system activity occurs, requested logs can be emailed to the configured email addresses. You can provide primary, 
secondary, or both recipient addresses. The primary and secondary addresses receive the same activity log alerts at the 
same time. 

To configure email delivery: 

1. Select Config > Settings. 

2. Select the Email tab. 

3. Provide the hostname/IP, port number, and from email address 

4. In the Send Email To fields, type the primary and/or secondary email address.  

5. Check the logs to be delivered. Both primary and secondary email recipients receive the same logs. 

6. Click Apply Changes.  

System 

The System option configures the SPM hostname. 

 

To configure SPM hostname: 

1. Select Config > Settings. 

2. Select the System tab. 

3. Provide the SPM hostname/IP address. 

4. Click Apply Changes.  
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Network 

The Network option specifies the primary and secondary ports for accessing SPM remotely. 

To configure the SPM network port: 

1. Select Config > Settings. 

2. Select the Network tab. 

3. Select System Port or Device port and complete the fields, as described below. 

4. Click Apply Changes. 

The System Port option is the primary port for SPM. It is recommended that you select the default option that names the 
IP address, subnet mask, and gateway instead of selecting the option for automatic IP address used for DHCP. 

 

The Device Port option is the secondary port for SPM.   

 

Web 

The Web option specifies the web port for SPM. 

 

To configure SPM web port: 

1. Select Config > Settings. 

2. Select the Web tab. 

3. Change the standard web port “80” to a port number within your network firewall. 

4. Click Apply Changes.  
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Telnet 

This option enables or disables Telnet and configures the standard Telnet port.  

 

To configure SPM Telnet web port: 

1. Select Config > Settings. 

2. Select the Telnet tab. 

3. Change the standard web port “23” to a port number within your network firewall. 

4. Click Apply Changes.  

Serial 
This option enables or disables the serial connection to SPM through the serial port located on the back of the SPM 
appliance. 

 

To configure SPM Serial connection: 

1. Select Config > Settings. 

2. Select the Serial tab. 

3. Check (or uncheck) the Enabled checkbox. 

4. Click Apply Changes.  

Database 

This option enables or disables the SPM database connection and configures the database port. 

NOTE: The Database tab displays only if you have the ODBC option enabled through your software key.   

 

1. Select Config > Settings. 

2. Select the Database tab. 

3. Check (or uncheck) the Enabled checkbox. 

4. Change the Database Port number, if necessary, but see NOTE below: 

NOTE: The 5432 port number is for the ODBC default PostgreSQL. If you change the 5432 port number, devices may send connected or 
unreachable email messages from SPM. 

5. Click Apply Changes.  
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About Telnet and Serial Connections 

 The Telnet and serial connections allow for a Reboot command and display the serial number of the machine. 

 The serial connection network parameters are: 

   Standard NULL modem cable 
   115200 bits per second 
   Data Bits = 8 
   Parity Bits = none 
   Stop Bit = 1 
   For Windows: the flow control value is the Windows default. 

 The default login name and password for Telnet and serial access is the same as the Sentry Power Manager web 
 default (username/password = admn/admn). Any administrative user created also has a working username and 
 password.   

 Changing the password of the admn login is strongly suggested and can only be done through 
        the web interface. The admn username and password can be changed but the admn account cannot be deleted. 

 All SPM administrative user accounts created can login through the serial and Telnet 
 connections. 
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Getting Help 

The following options are available on the Help menu for technical information and product support: 

Help Menu Options  

Option  Description 

Support  Contact information for SMARTER Technical Support and links to this user operations manual at Server
 Technology’s website. 

Licenses  (Administrator only) Allows update for an additional SPM license key; also displays the current number of 
 supported CDUs, and other  enabled features, such as Billing and ODBC. 

Help > Support 

The Help > Support option shows contact information for Server Technology’s SMARTER Technical Support. In addition, 
links are provided to the Server Technology website and to the Sentry Power Manager – Operations Manual. 

 



 

62   Using Sentry Power Manager  Sentry Power Manager  
                                                                          Operations Manual 

Help > License 

For the administrator: The Help > Licenses option allows the administrator to update to an additional SPM license key 
that supports more CDUs in the network.  

The page shows the number of CDUs supported under the current license key. The page also shows if the Billing reports 
feature and the ODBC feature are enabled.  

 
 

Click the Enter Additional License Key(s) button to display the following page: 

 

To apply a new SPM license key: 

1. Obtain the new license key from your Server Technology Account Representative at 800.835.1515 (domestic) or 
+00 (1) 775.284.2000 (international). An alpha-numeric key will be generated for you based on the serial number 
of the appliance that contains SPM. 

2. Type the new key you receive in the License Key field (shown above) and click Add. 

NOTE: To purchase additional Sentry Power Manager SPM Licenses, please contact your Server Technology representative at 1-800-835-1515 
(domestic), ++0 (1) 775.284.2000 (international), or sales@servertech.com. 
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Chapter 4: Appendices  
Appendix A: Technical Specifications 

Regulatory Compliance 

Products with the following mark comply with the RoHS Directive (2002/95/EC) issued by the 
Commission of the European Community. 

Recycling 

Server Technology Inc. encourages the recycling of its products.  Disposal facilities, environmental conditions 
and regulations vary across local, state and country jurisdictions, so Server Technology encourages consultation 
with qualified professional and applicable regulations and authorities within your region to ensure proper 
disposal. 

Waste Electrical and Electronic Equipment (WEEE) 

In the European Union, this label indicates that this product should not be disposed of with household waste.  It 
should be deposited at an appropriate facility to enable recovery and recycling. 

For information on how to recycle this product responsibly in your country, please visit: 
www.servertech.com/support/recycling. 

Appendix B: Warranty, Product Registration, and Technical Support  

Warranty 

For Server Technology Warranty information, please see our website. 

Product Registration 

Registration is your key to special offers and services reserved for Registered Users. 

 Excellent Technical Support Services 
 Special Update and Upgrade Programs 
 Warranty Protection 
 Extended Warranty Service 
 New Product Information 

Register your products online today! 

Technical Support 

 

Experience Server Technology's FREE SMARTER Technical Support - Learn more... 

Server Technology understands that there are often questions when installing and/or using a new product.  Free Technical 
Support is provided from 6:00 AM to 7:00 PM, Monday-Friday, Pacific Time. 

Server Technology, Inc. 
1040 Sandhill Drive Tel: 775.284.2000 Web: www.servertech.com 
Reno, Nevada  89521 USA Fax:  775.284.2065 Email: support@servertech.com 

Return Merchandise Authorization 

If you have a unit that is not functioning properly and is in need of technical assistance or repair: 

Please review Server Technology’s Return Merchandise Authorization process on our website. 
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